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SRA_Ch4� Creating preliminary spatial risk layers



The goal of SRA is to create a final spatial risk layer (or

surface) on a map of the study area (Figure 4.1).

Because the final spatial risk layer is in a raster format,

we need to convert the vector risk layers to the same

raster format to enable them to be combined. The

objective of this section is to create these preliminary

raster risk layers.”
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Figure 4.1: Spatial risk assessment steps
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No areal risk factors were investigated in our example,

but if there were, the goal of preparing an areal risk

factor layer is to create a heat map of risk factor density

attributes from centroids of spatial polygons. These

might optionally be weighted by an attribute variable that

is associated with the risk. For example, if animal

movements into a region were only available as

aggregated counts for a region instead of to point

locations, the attribute of number of animal movements

into a region could provide a weighting for that region, as

described in the next section.”
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Create a kernel-smoothed surface of distance from

points. This surface can optionally be weighted by an

attribute e.g. no. of animal movements, but these data

are not available for this example:”

In the Layers Pane highlight spatial point data file MMRMarketsActv

Menu bar -> Processing -> Toolbox -> (Type “Heatmap” search bar) ->
Interpolation -> Heatmap (Kernel Density Estimation)

Double click to open dialog box (Figure 4.2)

Parameters tab:

1. Point layer: MMRMarketsActv [EPSG:32646]

2. Radius: set to a maximum distance e.g. 50000m (50 km) over which the
locations might affect the risk of disease within that radius

3. Output raster size (set Rows to 200 and columns will set to appropriate
number)

4. Click Run

5. Click Close (when finished)
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Figure 4.2: Dialog box of settings for heatmap

 For further explanation about heatmaps one useful site for
information
is https://www.qgistutorials.com/en/docs/3/creating_he
atmaps.html 

https://www.qgistutorials.com/en/docs/3/creating_heatmaps.html


C O NT I NU E

Save image as a raster object and project to Project CRS: 

Right click newly-created “Heatmap” in Layers Pane

Save Raster Layer as … -> dialog box (Figure 4.3)

1. Format- GeoTIFF (denotes it is a raster file type)

2. File name- “ResData/Geo-Features/MMRMarketsActv_Rast”

3. CRS- Project CRS

4. Extent -> Calculate from Layer -> Select “MMR_0” (the polygon shape file
of study area boundary)

5. Click OK

and its link to ‘QGIS Heatmap Using Kernel Density
Estimation Explained’
at https://www.geodose.com/2017/11/qgis-heatmap-using-
kernel-density.html

https://www.geodose.com/2017/11/qgis-heatmap-using-kernel-density.html%E2%80%8B


Figure 4.3: Dialog box of settings to save heatmap as a raster file
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Optional- Enhance the appearance of the raster layer (note that changing

the symbols does not change the underlying data): 

Layers Pane- Right click on “MMRMarketsActv_Rast

Properties -> Symbology -> Dialog box (Figure 4.4)

1. Render type- Singleband pseudocolor

2. Color ramp -> All color ramps -> OrRd

3. Click OK



Figure 4.4: Dialog box of settings to edit settings for symbols of heatmap raster file
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Click ▶ to play the video



Placeholder for link to instruction video 4-2
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Examples of spatial lines risk factors are the road

network as proxy variables for legal (primary roads) or

illegal animal/animal product movements (secondary

roads). The aim of this section is to create a continuous

representation of the proximity of locations in the study

area to the different road types.

The first task is to convert the polylines spatial vector file

of roads to a raster file. This is necessary because the

following steps need to work with raster and not vector

spatial file types:”

Layers Pane: Select and highlight polylines spatial object for analysis (ResData/Geo-
Features/MMRRoadsPrim)

Menu bar: Raster -> Conversion -> Rasterize (Vector to Raster) -> Dialog box … (Figure 4.5)

1. Input shape file (“ResData/Geo-Features/MMRRoadsPrim”)

2. A fixed value to burn [optional]: Set to 1

3. Output raster size units: Select “Georeferenced units”

4. Width/Horizontal resolution = 1000
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5. Height/vertical resolution = 1000

6. Output extent Click button on right -> Calculate from layer -> “MMR_0” (with polygon icon) and the
extent should read as displayed

7. Assign a specified nodata value to output bands [optional]: Toggle to “Not set”

8. Click Run, and when finished click Close

Figure 4.5: Dialog box of settings to create a raster file of primary roads
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Right-click the newly-created layer “Rasterized” -> Export -> Save As ->
Dialog box:(Figure 4.6)

1. “ResData/Geo-Admin/MMRRoadsPrim_Rast”

2. Click OK



Figure 4.6: Dialog box of settings to save image of proximity to primary roads as a raster file
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Calculate closest distances to raster map of roads: 

Menu bar: Raster > Analysis > Proximity (Raster Distance)-> Dialog box…
(Figure 4.7)

1. Input layer- select “ResData/Geo-Admin/MMRRoadsPrim_Rast”)

2. Distance units- select “Georeferenced coordinates”

3. No data value to use for destination proximity raster: Toggle to “Not set”

4. Click “Run” and when finished click “Close”



Figure 4.7: Dialog box of settings to create image of proximity to primary roads
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Export and save the newly created “Proximity map” layer: 



Right click “MMRRoadsPrim_Rast_Prox” -> Export -> Save As - Dialog box
…(Figure 4.8)

1. Name file in “ResData/Geo-Admin/” folder as
“MMRRoadsPrim_Rast_Prox

2. Click “OK”



Figure 4.8: Dialog box of settings to save image of proximity to primary roads as a raster file

C O NT I NU E

Repeat process for secondary roads but substitute “Sec”

for “Prim” in the file name.”

Click ▶ to play the video

Placeholder for link to instruction video 4-3

“
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The goal of this processing step is to ensure that the pixel

values of the different preliminary raster risk layers are in a

suitable form to combine, and that their values make logical

sense.

The first step is to normalise the raster values within each

raster cell by dividing its value by the maximum value in the

raster file (the maximum score procedure) to create pixel

values between 0 and 1. We will use “MMRRoadsPrim_Rast” as

an example:”

Copy maximum raster layer value to use in next calculation (Figure 4.9)

1. Right click on newly-created raster proximity file in Layers Pane ->
Properties -> Information ->

2. Locate ‘Band 1’ - STATISTICS_MAXIMUM’ and copy value to computer
clipboard (Control + C) and close information box
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Figure 4.9: Raster file properties pane displaying maximum raster value
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Menu bar: Raster -> Raster calculator -> Dialog box … (Figure 4.10) 



1. In the Raster Bands box double click on the chosen file and raster layer to
operate so that it appears in the Raster Calculator Expression box

2. Raster Calculator Expression: Divide the selected raster layer values by
the copied maximum value

3. Result layer Output layer: Rename file as
“MMRRoadsPrim_Rast_Prox_Norm” in the ResData/Geo-Features folder
and click Save

4. Output CRS: Should read as the project CRS EPSG:36246 - WGS 84 /UTM
zone 46

5. In dialog box click OK



Figure 4.10: Raster calculator settings used to normalise raster layer

 Repeat these steps for the other raster risk factor layers
from the previous operations, renaming them with the
same conventions.
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The second step is to correct the pixel values for raster layers

of distances from spatial lines so that they make logical sense.

Currently, the pixel values reflect the real distance to the

closest road, that is, increased distance equates to increased

values. But we want pixel values with increased distance to

equate to reduced risk e.g. distance to primary roads.

To achieve this, we create a new raster layer calculated as 1 -

normalized value. In this way greater values are nearer the

road, denoting increased risk with increased proximity, and

lesser values are further from the road, denoting decreased

risk with decreased proximity. We achieve this by using the

raster calculator again:”

Menu bar: Raster -> Raster calculator -> Dialog box … (Figure 4.11)

1. Double click on the file and raster layer to operate on
(“MMRRoadsPrim_Rast_Prox_Norm@1”) so that it appears in the Raster
Calculator Expression box

2. Raster Calculator Expression: 1 - selected raster layer values

3. Result file: Rename file as “MMRRoadsPrim_Rast_Prox_Norm_Inv” and
click Save

4. In dialog box click OK

“



Figure 4.11: Raster calculator settings used to correct proximity values
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The third step is to deal with missing or “no data” values. The



“

Repeat this process for the secondary roads, naming the
files with the same conventions.



raster calculator can’t function on pixels in the stacked layers if

any of the aligned pixels have missing (no data) values. The

next step, therefore, is to remove ‘no data’ pixels from any

raster image where their pixels do not entirely cover the extent

of the study area to allow the raster calculator to work with

these pixels in other layers. For our exercise, this step applies

to the normalised raster file of livestock markets heat map:”

In Toolbox menu click on Toolbox icon -> Processing Toolbox pane

Search for “No data”

Raster tools -> Fill NoData cells

Double click on Fill NoData cells-> Dialog box (Figure 4.12)

1. Select “MMRMarketsActv_Rast_Norm”

2. Fill value: Set to 0

3. Output raster: Click folder button to right “Save to file …” and name new
file as “MMRMarketsActv_Rast_Norm_NoNA” in “ResData-Features”
folder

4. Click Run and when finished click Close



Figure 4.12: Fill NoData cells dialog box used to correct raster layer with no data values
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Click ▶ to play the video

Placeholder for link to instruction video 4-4
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There are often several choices that need to be made

when creating raster spatial risk layers. 

Create a table that allows you to answer the following

questions:

1. For each spatial risk layer, identify the optional values
that you could have used when creating the raster
risk layer

2. Describe the likely effects on the risk layer raster
values and what that might mean for the final spatial
risk map after the layers are combined
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Have you completed the table as requested?



SUBMIT
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Table 4.1: Possible effects of changing parameters for GIS functions used to

create final spatial risk assessment map for occurrence of FMD in Myanmar

Spatial risk

factor

Parameters with optional

values Effect of changing parameters on final risk map

Proximity to

livestock

markets

Heatmap (Kernel Density

Estimation)- Radius

Increased radius would increase the area around

the markets influenced by the market and likely

enclose more actual outbreak locations

  Heatmap (Kernel Density

Estimation)- Kernel shape

A view of the possible kernel shapes shows that

apart from uniform, they differ little from the

default quartic shape, so alternate valid shapes

would likely have little effect

Proximity to

roads

N/A  

Population N/A  

Yes

No



C O NT I NU E

Congratulations - end of lesson reached

density of

livestock


