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SRA_Ch3� Data management for spatial risk
assessment



The overall GIS process within SRA involves following six

steps that continue on from the MCDA steps (Figure 3.1).

The MCDA and GIS steps are closely linked at GIS step

five where the spatial weights resulting from the MCDA

described in Chapters 1 and 2 combined with the results

of GIS processing to create a final risk map.”

Lesson 1 of 5

3.1 Use of geographic information systems in
spatial risk assessment

“



Figure 3.1: Workflow of spatial risk assessment processes
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It is important to understand that GIS spatial data that

represent the risk factors required for SRA must be either

available in a raster format, or be eventually converted to

a raster format to combine the various risk factors into a

single SRA map. However, often these spatial data do not

exist in raster format and instead, spatial data in other

formats, such as spatial lines or spatial polygons, must

be firstly sourced and then transformed to the required

raster format. This process of acquiring and transforming

spatial data consumes much of the work in the GIS

component of SRA.

Therefore, the purpose of the GIS steps 3 and 4 is to

create separate raster files for each risk factor, creating

multiple risk “layers”, in forms that can be combined.

Increasing pixel values in each layer should represent an

increased risk of disease occurrence, and the values

should be scaled so that they span values between 0 and

1. 

Lesson 2 of 5

3.2 Preliminaries

“



These normalised (values transformed to range 0 - 1)

risk layers can then be combined by multiplying each by

their own spatial weight created from the MCDA process,

and then mathematically added to each other to create a

final weighted risk surface.”
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The following subsections describe how to locate open-

source spatial data, and some of their types and uses for

SRA.”

Lesson 3 of 5

3.3 Acquiring digital maps of the study area and
spatial risk factors

There are many open-source (free for non-profit use) spatial data
repositories. These data have a wide range of types, formats and
attributes, and only some may be of value for animal health GIS and
SRA purposes. Additionally, their file sizes are often large, meaning
they can be slow to download, consume large quantities of computer
storage capacity, and need additional processing before they can be
used. Additionally, some spatial data may not be available publicly or
from government and may need to be collected by the researcher or
analyst. Together, this means that considerable effort and time may
be needed to locate, acquire, and process spatial data for SRA
projects.

“
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3.3.1 GADM data

The GADM database of global administrative areas provides digital

maps in a range of file formats for state boundaries and lower-level

administrative areas:

Spatial data in vector polygon format of country administrative

regions can also be downloaded from the GADM

website: https://gadm.org/download_country_v3.html

For example, Myanmar has formats Geopackage, ESRI

“Shapefile”, two R formats (sp and sf) and Google KMZ

format. For the purposes of this course, we will use the

“Shapefile” format. The files have the suffix “0” for state

boundaries, then suffixes in increasing integer numbers

for successively smaller administrative regions. The

coordinate reference system and datum for these files

are longitude/latitude and WGS84, respectively.”

3.3.2 OpenStreetMap project

“

https://gadm.org/download_country_v3.html


OpenStreetMap (OSM, https://www.openstreetmap.org) data are, as

suggested by it’s name, open-source, and created by public users.

Spatial files of a wide range of geographic features are available, but

for the purposes of this course we will focus on roads, but many

more features are also available (see below). 

These OSM data can be acquired directly from within QGIS or from

the geofabrik website: http://download.geofabrik.de/

 

The country files are located under the Sub Region, and

the Quick Link for the “shp.zip” file for that country

provides a download for a zipped shapefile in the file

format which we will use, which needs to be unzipped

once it is downloaded. These files potentially contain a

large number of features, and more information about

each can be found at the following links.”

“

Population Centres –

https://wiki.openstreetmap.org/wiki/Map_Features#Place

http://download.geofabrik.de/
https://wiki.openstreetmap.org/wiki/Map_Features#Place


Roads –

https://wiki.openstreetmap.org/wiki/Map_Features#Roads

Railways –

https://wiki.openstreetmap.org/wiki/Map_Features#Railway

Ports –

https://wiki.openstreetmap.org/wiki/Tag:landuse%3Dport

Airports –

https://wiki.openstreetmap.org/wiki/Map_Features#Aeroway

  Maps of these spatial data features may be converted to
vector maps as described in the following tutorial:

https://www.qgistutorials.com/en/docs/3/downloading_os
m_data.html

https://wiki.openstreetmap.org/wiki/Map_Features#Roads
https://wiki.openstreetmap.org/wiki/Map_Features#Railway
https://wiki.openstreetmap.org/wiki/Map_Features#Aeroway
https://www.qgistutorials.com/en/docs/3/downloading_osm_data.html
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3.3.3 Livestock demographic and health data

Some freely-available livestock spatial data is available, but it is

often aggregated and additionally may not be current. Common

sources include:

Gridded Livestock of the World (GLW) maps provided by FAO

These raster format data estimate livestock density (in units
of number of animals per pixel), at a resolution of 5 minutes
of arc (approximately 10 km at the Equator)

The current (July 2021) data is version 3 for the year 2010,
with maps available for sheep, pigs, horses goats, ducks,
cattle, chickens and buffaloes

https://dataverse.harvard.edu/dataverse/glw_3

Background information about these data are found
at http://www.fao.org/livestock-systems/global-distributions/en/,
with links from that page to the various species

Several maps are available for each species, and the
differences between them are described in the metadata file

https://dataverse.harvard.edu/dataverse/glw_3
http://www.fao.org/livestock-systems/global-distributions/en/


The precise year of data collection and resolution of the data
varies by country

For our purposes, the maps produced by the dasymetric
method (files contain the “_DA” suffix) in the “tif” format are
the most appropriate

National animal health and surveillance data may also be
available (but may not be freely available)
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3.3.4 Miscellaneous data

A wide range of data physical and human geography data can be

obtained from the following sources:

UNEP Environmental Data Explorer –

http://geodata.grid.unep.ch

FAO GeoNetwork –

http://geodata.grid.unep.ch/
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http://www.fao.org/geonetwork/srv/en/main.home

The World Bank DataBank –

http://databank.worldbank.org/data/home

http://www.fao.org/geonetwork/srv/en/main.home
http://databank.worldbank.org/data/home


3.4.1 Background and data for this case study

We will use as an example the SRA process undertaken

at the OIE-GIS course for animal health run in Nay Pyi

Taw, Myanmar, in October 2019. This was a hypothetical

example used as a training exercise during the course,

with the aim that the course participants could learn the

methods and further develop and apply them in their own

countries. The participants from Myanmar and the Laos

Democratic Republic and representatives from OIE who

took part in the exercise were the ‘experts’ in the MCDA

process, from which we have used data in previous

exercises. Throughout this chapter.”

Spatial risk factor data for this case study includes:

Lesson 4 of 5

3.4 Case study: Spatial risk assessment for
incursion and spread of FMD in Myanmar

“



1. Livestock markets –

The raw data is a CSV file that includes the point locations of markets in
geographic coordinates (longitutde and latitude) in decimal degrees and
market status (active or not active)

2. Roads –

Classified as primary and secondary

The raw data is an ESRI shapefile with geographic CRS sourced from
OSM

These road categories are handled separately for the exercise to
demonstrate the method, although the distinction between primary and
secondary roads as risk factors is not made in this case study

3. Pig population density –

The raw data are sourced from FAO’s Gridded Livestock of the World
source provided as a tiff file and geographic CRS

4. Cattle population density –



Download these data as a single zip file “RawData.zip”

from the Stream site - Spatial risk assessment section in

the “Spatial risk assessment files” folder. This is a large

file and may take several minutes to download

depending on your internet speed.”
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3.4.2 Create and set up a QGIS project
Each QGIS project needs to be set up and saved so that you can return to the

same place in your work as when you left it last. The project file you are

about to create stores information on the locations of the various files you

work with.

On the menu bar click “Project” -> “New”

A blank Layers pane and map palette will appear

On the menu bar click “Project” -> “Save As” and either create a new
folder in your highest level project folder or add it to an existing one if that

The raw data are sourced from FAO’s Gridded Livestock of the World
source provided as a tiff file and geographic CRS

“



is appropriate

Give the QGIS project a meaningful name to you like “MMR-FMD-SRA”-
which identifies the country and purpose of your project

Click ”Save”

You can set various parameters, but for our purposes, the

most important is the coordinate reference system

(CRS):

On the menu bar click “Project” -> Properties -> CRS
(Figure 3.2)

a. Select coordinate reference system that is
appropriate for the study area, in this case WGS
84 / UTM zone 48N

b. Click “OK”

You can set various parameters, but for our purposes, the most important is

the coordinate reference system (CRS):

On the menu bar click “Project” -> Properties -> CRS (Figure 3.2)

a. Select a coordinate reference system that is appropriate for the
study area, in this case, WGS 84 / UTM zone 48N

b. Click “OK”

“



Figure 3.2: Set project CRS

Click ▶ to play the video



Placeholder for link to instruction video 3-4-2
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3.4.3 Project file management

It is important to organise an SRA project in a way that makes it easy

to store and later locate the large number of spatial data files in an

SRA project that need processing. If spatial data are stored in a

disorganised way, the work of the analyst will be harder, take longer

and be more error-prone. 



Each analyst will eventually need to use a system that is meaningful

to them, but if you are uncertain of where to start, I suggest the

following folder names and structure to organise files, with each

indent denoting a separate level of sub-folders, followed by a

description of files to store in them. The names in speech marks are

the names that are used in the exercises in this course, but you can

use names that make sense to you, don’t type in the speech marks,

use identical case of letters (upper or lower) and don’t use spaces in

folder or file names.

The suggested QGIS spatial project structure is set out in the

following way:

“SEACGISCourse2022”- Project folder with an informative name

“QGISProj”- folder for QGIS project file (should be defined
when project first created and never changed)

“Data”- folder for storage of all types of data you use in your
project (mainly spatial data in this project)

“RawData”- Folder for all data in the original form that you
acquire it

“Geo-Admin”- Spatial data of administrative regions,
typically spatial polygons of the study area

“Geo-Features”- Spatial data on geographic features,
such as roads, population centres etc.



“Geo-Livestock”- Spatial data on livestock populations,
typically raster files of cattle, pig population density

“ResData”- Folder for all data that you process for later
use, with the same subfolder structure as the “RawData”
folder. When a file from a “RawData” subfolder is
processed, save it in its new form into the subfolder of
the same name in the “ResData” folder. Add one
additional folder:

“Geo-Final”- Folder to store final spatial SRA result
files

The GIS steps create intermediate files which should be

renamed and saved for checking for obvious errors. If the

files are renamed in a systematic way, then each file

representing a step in the process can be readily

retrieved. 

The result of one operation are usually passed to the

next operation, and if an error arises, it is easier to

troubleshoot backwards one step at a time to find and

solve the problem, rather than starting from the last step

when you don’t know at which step the problem

occurred.””

“



3.4.4 Import raw project spatial files

Complete the following steps to organise your raw data and results

files:

Create folder named “Data” within the
“SEACFMDGISCourse2022” folder

Create folder “ResData” within the “Data” folder

Download the raw data in a zip file “RawData.zip” from the
Stream site (click HERE) - Spatial risk assessment section in the
“Spatial risk assessment files” folder

Unzip the file into the “Data” folder

You will have created a “RawData” folder within the “Data” folder,
and further subfolders for files according to the type of
geographic features they represent (Figure 3.3)

“Geo-Admin” with GADM administrative region shapefiles

“Geo-Features” with livestock markets, OSM features such as
roads etc

“Geo-Livestock” with pig and cattle population density raster
files

“Geo-Admin” with GADM administrative region shape files

“Geo-Features” with livestock markets, OSM features such as
roads etc

https://stream.massey.ac.nz/mod/folder/view.php?id=4112602&forceview=1


“Geo-Livestock” with pig and cattle population density raster files

Figure 3.3: Suggested data folder structure

Click ▶ to play the video

Placeholder for link to instruction video 3-4-4
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3.4.5 Project, save and visualise spatial files

Spatial files are frequently available with the geographic CRS

(longitude and latitude measured in degrees) and must be projected

to the local CRS with distance units because SRA requires GIS

operations that require distance-based calculations. We will be

dealing with different spatial data types- areal (such as

administrative regions), point (such as locations of livestock

markets), lines (such as roads) and raster (such as livestock

density), many of which need to be projected first before further

processing, but the process is essentially the same for each data

type.

3.4.5.1 Spatial areal files- study area

A spatial areal file is always necessary to define the study area and create a

boundary for your analysis. Import the study area file of the state of

Myanmar into your QGIS project in the following steps:

Left-click and drag the study area spatial file (RawData/Geo-
Admin/gadm36_MMR_0.shp) from the Browser Pane onto the map
palette



In Layers Pane right-click on the layer file -> Export -> Save Features As …
-> Dialog box (Figure 3.4)

a. File name “MMR_0” in Layers Pane “-Admin" (this is the directory in
which you are saving the projected file and the name you are giving
to it)

b. In CRS box change to “Project CRS: EPSG:32646 - WGS 84 / UTM
zone 46N

c. Click OK



Figure 3.4: Project raw study area file to local CRS and save to new folder

View the projected study area map (Figure 3.5) (your

colour and fill settings may vary from those shown)”

“



Figure 3.5: View of the projected study area map

Click ▶ to play the video



Placeholder for link to instruction video 3-4-5-1

3.4.5.2 Spatial areal risk factors
Areal risk factors include those where a risk factor, for example, livestock movement numbers, are

aggregated at an administrative region level (note that in this exercise no spatial areal risk factor files are

used).

In this example of SRA for the occurrence of FMD in

Myanmar, no spatial areal risk factor was chosen in the

causal path diagram, so the method is not fully shown

here, but if it were, the following options could be used to

“



create spatial point data representing polygon centroids

of level 2 administrative regions”

Highlight the polygon layer for which you want to identify centroids

Menu bar -> Vector -> Geometry tools -> Centroids -> Dialog box (Figure 3.6)

1. Select input layer

2. Check “Create centroid for each part”

3. Click “Run”

Save the centroids in the appropriate folder with a meaningful name as a

new point vector layer with the project CRS

Process the administrative region centroids as if they were spatial point data



Figure 3.6: Calculate polygon centroids
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3.4.5.3 Spatial points risk factors

Examples of spatial points risk factors are animal market locations,

administrative area centroids, etc. provided as csv or other file types.



Import and project CSV or other point location data:

Data Source Toolbar (2nd row, left hand side): Open Data Source Manager ->

Delimited Text (left pane) -> Dialog box … (Figure 3.7)

1. Filename: Click folder button on far right and navigate to
“Data/RawData/Geo-Features” folder and select “MMRMarkets.csv” file

2. File format: Select appropriate delimiter- CSV (comma separated values)
if not already selected

3. Record and Fields Options: Check “First record has field names”

4. Geometry Definition

a. X field should display “Longitude” and the Y field display “Latitude”

b. Geometry CRS should display “EPSG:4326 - WGS 84”- this is
appropriate for the longitude-latitude coordinates used in the CSV file

5. Click Add, Click Close- the file is added to the Layers pane and displayed
on the Map Palette



Figure 3.7: Import CSV data file with spatial features

Save as a new layer projected with correct CRS:

In Layers Pane right-click on the MMRMarkets layer file -> Export -> Save

Features As … -> Dialog box … (Figure 3.8)

1. Format ESRI Shapefile and File name: Save as “MMRMarkets” in
Data/ResData/Geo-Features directory

2. In CRS box check projection is defined as “Project CRS: EPSG:32646 -
WGS 84 / UTM zone 48N”



3. Check that all the fields are selected (the default)

4. Select “Point” for the geometry type

5. Extent: Tick check box -> Calculate from layer -> Select “MMR_0” (if
MMR_0 is in the Layers Pane)

6. Click OK



Figure 3.8: Project and save file

Filter MMRMarkets so that only the geographic features (in this case the

“active” markets) that should be analysed are retained:



Right-click MMRMarkets in Layers pane

Click on “Open Attribute Table”

Click on “Select/filter features using form” button (Figure 3.9)

1. Click in “Remark” field and type “active” (it will auto-fill)

2. Select “Equal to (=) toggle button to right (not”Contains” as the other
category is “not active” and that option would select those also)

3. At bottom of form, click “Select Features” button then close or minimise
the form

Figure 3.9: Filter and select only active markets for analysis

Save selected features as a new file:



Right-click MMRMarkets in Layers pane -> Export -> Save Selected Features

as -> Dialog box … (Figure 3.10)

1. File name : Locate ResData/Geo-Features folder and type
“MMRMarketsActv”

2. CRS: Select “Project CRS: EPSG:32646 - WGS 84 / UTM zone 46N”

3. The tick box “Save only selected features” should be selected

4. Select Point Geometry

5. Add a extent for the layer from the MMR_0 study area shape file

6. Click OK

View projected spatial points file (Figure 3.11)

Click ▶ to play the video

Figure 3.10: Save selected
features as a new file

Figure 3.11: Map of active
livestock market locations in
Myanmar



Placeholder for link to instruction video 3-4-5-3a



Placeholder for link to instruction video 3-4-5-3b

CONTINUE

3.4.5.4 Spatial lines risk factors

Examples of these types of data are the road network as proxy variables to

represent legal (primary roads) or illegal animal/animal product movements

(secondary roads), or borders with neighbouring countries across which there

is illegal movement of animals or animal products.

Open the spatial lines file:



Browser Pane: Drag spatial lines file “gis_osm_roads_free_1” from

RawData/Geo-Features/ onto Map PaletteFilter the road type required

Select “gis_osm_roads_free_1” in Layers Pane

Attributes Table toolbar: Right click -> Open Attribute Table -> Dialog box
(Figure 3.12)

1. Click icon “Select/filter features using form”

2. Select “fclass” field and type in “primary” (the category will autofill) and
the right hand option box should read “Contains”

3. Click Select Features and close dialog box

Figure 3.12: Dialog box of settings to filter primary roads



Export the selected features as a new projected layer:

In the Layers pane, right-click the layer from which features have been

selected (gis_osm_roads_free_1)-> Export -> Save Selected Features As … ->

Dialog box (Figure 3.13)

1. Choose format (ESRI Shapefile) and create file name: “…ResData-
Features.shp”

2. CRS: (EPSG:32646)

3. Check “Save only selected features”

4. Geometry type “LineString”

5. Extent- calculated from MMR0 study area extent

6. Click OK



Figure 3.13: Dialog box of settings to project and save primary roads shape file

View the primary road network“



Then, repeat the filter and projection steps for the

secondary roads as for the primary road network”

Click ▶ to play the video

Placeholder for link to instruction video 3-4-5-4

CONTINUE

3.4.5.5 Spatial raster files



Examples of possible spatial risk factor layers that can be obtained as raster

files are disease vector or reservoir or target animal species density from

FAO Gridded Livestock of the World, such as those for livestock species like

pigs or cattle.

Pig population as indicator for risk of swill feeding:

Browser Pane: Drag spatial lines file “gis_osm_roads_free_1” from

RawData/Geo-Features/ onto Map PaletteFilter the road type required

Browser Pane: Drag “5_Pg_2010_Da.tif” from “-Livestock" folder onto Map
Palette

Processing Toolbox (box on right hand side of screen)

Add search term “Warp” to search bar and enter

Double-click GDAL Raster projections-Warp (reproject) -> Dialog box:
(Figure 3.14)

1. Input layer: “5_Pg_2010_Da”

2. Target CRS: EPSG:32646 - WGS 84 / UTM zone 46N”

3. Click “Run”



Figure 3.14: Dialog box of settings to warp (re-project) pig population density from geographic
to project CRS

A new raster file named “Reprojected” has appeared in the Layers pane:

Click on “Reprojected” file in Layers pane

In top line of menu bar click Raster -> Extraction -> Clip raster by Extent ->
Dialog box (Figure 3.15):



1. Input layer: Reprojected

2. Clipping extent: Click button to right and select “Calculate from layer” ->
MMR_0

3. Run

Figure 3.15: Dialog box of settings to clip projected pig population density to extent of study
area



A new raster file named “Reprojected” has appeared in the Layers pane:

Right-click this file “Clipped (extent)” -> Export -> Save Raster Layer as:
(Figure 3.16)

1. Filename (Create new folder named “Geo-Livestock” in “ResData” folder
and save file with name “Pig_2010_Da_Clip

2. CRS should read “EPSG:32646 - WGS 84 / UTM zone 46N”

3. Extent Calculate from layer MMR_0

4. Click OK



Figure 3.16: Dialog box of settings to save clipped pig population density as a new raster file

Repeat steps for the cattle population density as an

indicator of risk of susceptibility to infection. Replace

“Pig” with “Cattle” in the file names.”

“



Click ▶ to play the video

Placeholder for link to instruction video 3-4-5-5

Create a table that allows you to answer the following

questions:

Describe the spatial distribution of the risk factors chosen
for this exercise.

How might the distributions of each risk factor relate to or
interact each other and what might be the effect of these
patterns on the epidemiology of FMD that we are
concerned with?

“



Hint: You will need to adjust the order that maps are layered

and the symbols they use to appreciate the patterns in the

data.”

CONTINUE



Create a table that allows you to answer the following

questions:

Describe the spatial distribution of the risk factors chosen
for this exercise

How might the distributions of each risk factor relate to or
interact with each other and what might be the effect of
these patterns on the epidemiology of FMD that we are
concerned with?

Hint: You will need to adjust the order that maps are layered

and the symbols they use to appreciate the patterns in the

data.”

Lesson 5 of 5

Exercise 3.1� Describe the spatial risk factors

“

Have you completed the table in Exercise 3.1?

Yes

No



SUBMIT

CONTINUE

The visual appearance of spatial patterns of each risk factor and how they

might relate to or interact with each are shown in Table 3.1.

Table 9.2: Spatial patterns and relationships of risk factors assessed for

occurrence of FMD in Myanmar

Spatial risk

factor Visual pattern Relationship to other risk factors

Livestock

markets

Concentrated in central MMR and few

others extending to delta regions

Closely associated with primary roads

and livestock density (particularly

cattle)

Roads

(primary)

Mainly in central MMR and extending to

Delta region. Few in border areas

Associated with cattle and pig

population density

Roads

(secondary)

Follow primary road network with few

additional roads in border and coastal

regions

As above

Pig

population

density

Concentrated in central and delta

regions of MMR

Associated with road networks



It seems that FMD-susceptible livestock are concentrated in

central Myanmar and this industry is serviced by a denser road

network and several livestock markets- all factors that would

contribute to the incursion and spread of FMD.”

CONTINUE

Congratulations - end of lesson reached

CONTINUE

Spatial risk

factor Visual pattern Relationship to other risk factors

Cattle

population

density

Similar pattern to pig population density Associated with road networks and

livestock markets

“


