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1 Overview of GIS steps in SRA 

It is important to understand that GIS spatial data that represents the risk factors required 
for SRA must be either available in a raster format, or be eventually converted to the raster 
format to combine the risk factors into a single SRA map. However, often these spatial data 
do not exist in raster format and instead, spatial data in other formats, such as spatial lines 
or spatial polygons, must be firstly sourced and then transformed to the required raster 
format. This process of acquiring and transforming spatial data consumes much of the 
work in the GIS component of SRA. 

It is very valuable to organise a SRA project in a way that makes it easy to store and later 
locate the large number of spatial data files in an SRA project that need processing. If 
spatial data are stored in a disorganised way, the work of the analyst will be harder, take 
longer and be more error-prone. Each analyst will eventually need to use a system that is 
meaningful to them, but if you are uncertain of where to start, I suggest the following folder 
names and structure to organise files, with each indent denoting a separate level of sub-
folders, followed by a description of files to store in them. The names in speech marks are 
the names that are used in the exercises in this course, but you can use names that make 
sense to you, don’t type in the speech marks, use identical case of letters (upper or lower) 
and don’t use spaces in folder or file names. QGIS spatial project structure 

• “SEACGISCourse2021”- Project folder with an informative name 



– “QGISProj”- folder for QGIS project file (should be defined when project first 
created and never changed) 

– “Data”- folder for storage of all types of data you use in your project (mainly 
spatial data in this project) 

• “RawData”- Folder for all data in the original form that you acquire it 

– “Geo-Admin”- Spatial data of administrative regions, typically 
spatial polygons of the study area 

– “Geo-Features”- Spatial data on geographic features, such as 
roads, population centres etc. 

– “Geo-Livestock”- Spatial data on livestock populations, typically 
raster files of cattle, pig population density 

• “ResData”- Folder for all data that you process for later use, with the 
same subfolder structure as the “RawData” folder. When a file from a 
“RawData” subfolder is processed, save it in its new form into the 
subfolder of the same name in the “ResData” folder, with one additional 
folder: 

• “Geo-Final”- Folder to store final spatial SRA result files 

The GIS steps create intermediate files which should be renamed and saved for checking 
for obvious errors. If the files are renamed in a systematic way, then each file representing 
a step in the process can be readily retrieved. The result of one operation are usually 
passed to the next operation, and if an error arises, it is easier to trouble shoot backwards 
one step at a time to find and solve the problem, rather than starting all over again. 

2 SRA-GIS steps in QGIS 

An important concept to keep in mind is that the purpose of the GIS steps 3 and 4 is to 
create separate raster files for each risk factor, creating multiple risk “layers.” Increasing 
pixel values in each layer should represent increasing risk of disease occurrence, and the 
values should be scaled so that they span values between 0 and 1. These normalised risk 
layers can then be combined by multiplying each by their own spatial weight created from 
the MCDA process, and then mathematically adding each layer together to create a final 
weighted risk surface. 

The steps laid out below follow the pattern shown in Figure ??. 



 

Figure 2.1: Spatial risk assessment steps 

Spatial risk factor data for this case study includes: 

1. Livestock markets (active markets only) 

2. Roads- primary and secondary (these are handled separately for the exercise to 
demonstrate the method, although the distinction between primary and secondary 
roads as risk factors is not made in this case study) 

3. Pig population density 

4. Cattle population density 

Download these data from the Stream site - Spatial risk assessment section in the “Spatial 
risk assessment files” folder 

3 Background to case study 

We will use as an example the SRA process undertaken at the OIE-GIS course for animal 
health run in Nay Pyi Taw, Myanmar, in October 2019. This was a hypothetical example 
used as a training exercise during the course, with the aim that the course participants 
could learn the methods and further develop and apply them in their own countries. The 
participants from Myanmar and the Lao Democratic Republic and representatives from OIE 
who took part in the exercise were the ‘experts’ in the MCDA process, from which we have 
used data in previous exercises. 

4 Preliminary steps for GIS analysis 
1. Create QGIS project 

2. Create folders to store files 



3. Menu bar -> Project -> Properties -> CRS -> Coordinate reference systems of the world 
-> WGS 84 / UTM zone 46N (appropriate Myanmar study area), click OK 

5 GIS steps 

5.1 Acquire spatial risk and study area files 
1. Copy spatial data files into their appropriate folders if not already done 

2. Import study area file- Menu bar : Layer ->  Create Layer -> New Shape File Layer OR 
Drag study area spatial file (RawData/Geo-Admin/MMR_0) from Browser Pane 
viewing the RawData folders onto map palette 

5.2 Project country boundary file for study area to the local CRS 
1. In Layers Pane right-click on the layer file -> Export -> Save Features As … -> Dialog 

box 

1. File name (ResData/Geo-Admin folder/MMR_0) 

2. In CRS box change to "Project CRS: EPSG:32646 - WGS 84 / UTM zone 46N 

5.3 Convert vector risk layers to raster risk layers 
1. Spatial points risk factors e.g. administrative area centroids, animal market locations 

etc. provided as csv or other file types 

1. Import and project CSV or other point location data 

1. Data Source Toolbar (2nd row, left hand side): Open Data Source 
Manager -> Delimited Text (left pane) -> 

1. File name: Select MMRMarkets.csv from Data/RawData/Geo-
Features folder 

2. File format: Select appropriate delimiter- CSV (comma separated 
values) 

3. Geometry Definition 

1. X field should display “Longitude” and Y field display 
“Latitude” 

2. Geometry CRS should display “EPSG:4326 - WGS 84” 

4. Click Add, Click Close 

5. Points now displayed as “MMRMarkets” as a new layer in Layers 
Pane 

2. Save as a new layer projected with correct CRS- 

1. In Layers Pane right-click on the MMRMarkets layer file -> Export 
-> Save Features As … -> Dialog box 

1. Format ESRI Shapefile 

2. File name: Save as “MMRMarkets” in Data/ResData/Geo-
Features directory 

3. In CRS box check projection is defined as “Project CRS: 
EPSG:32648 - WGS 84 / UTM zone 48N” 



4. Extent: Tick check box- the words “(current: MMR_0)” 
should display 

5. Click OK 

6. Remove previous MMRMarkets layer with CRS EPSG:4326 
- WGS 84 from Layers pane 

3. Filter MMRMarkets so that only the geographic features (active markets 
and not not active markets) that should be analysed are retained 

1. Right-click MMRMarkets in Layers pane 

2. Click on “Open Attribute Table” 

3. Click on “Select/filter features using form” button 

4. Click in “Remark” field and type “active” (it will auto-fill) 

5. Select “Equal to (=) toggle button to right (not”Contains" as the 
other category is “not active” and that option would select those 
also) 

6. At bottom of form, click “Select Features” button 

7. Close 

8. Right-click MMRMarkets in Layers pane -> Export -> Save 
Selected Features as -> Dialog box 

1. File name : Locate ResData/Geo-Features folder and type 
“MMRMarketsActv” 

2. CRS: Select “Project CRS: EPSG:32646 - WGS 84 / UTM 
zone 46N” 

3. The tick box “Save only selected features” should be 
selected 

4. Click OK 

2. Create a kernel-smoothed surface of distance from points. This surfaced can 
optionally be weighted by an attribute e.g. no. of animal movements, but these 
data are not available for this example 

1. Highlight spatial point data file MMRMarketsActv 

2. Menu bar -> Processing -> Toolbox -> (Type “Heatmap” search bar) -> 
Interpolation -> Heatmap (Kernel Density Estimation) 

3. Double click to open dialog box 

4. Parameters tab: 

1. Radius: set to the maximum distance e.g. 50000m (50 km) over 
which the locations might affect the risk of disease within that 
radius 

2. Output raster size (set Rows to 200 and columns will set to 
appropriate number) 

3. Click Run 

5. For further explanation see: 
https://www.qgistutorials.com/en/docs/3/creating_heatmaps.html and 
its link to QGIS Heatmap Using Kernel Density Estimation Explained 

https://www.qgistutorials.com/en/docs/3/creating_heatmaps.html


https://www.geodose.com/2017/11/qgis-heatmap-using-kernel-
density.html 

3. Save image as a raster object 

1. Right click “Heatmap” in Layers Pane 

2. Save Raster Layer as … -> dialog box 

1. Format- GeoTIFF 

2. File name- “ResData/Geo-Features/MMRMarketsActv_Rast” to 
denote it is a raster file 

3. CRS- Project CRS 

4. Extent -> Calculate from Layer -> Select “MMR_0” 

5. Click OK 

4. Optional- In Layers Pane- Right click on "MMRMarketsActv_Rast 

1. Properties -> Symbology -> 

1. Render type- Singleband pseudocolor 

2. Color ramp -> All color ramps -> OrRd 

3. Click OK (note that changing the symbols does not change the 
underlying data) 

2. Spatial areal/polygon risk factors e.g. livestock movements aggregated at an 
administrative region level (note that in this exercise no spatial areal risk factor files 
are used) 

1. Options (others possible): 

1. Create spatial point data representing polygon centroids and follow 
steps as above 

2. Create new attribute of risk factor density for each polygon and create a 
raster layer from it 

3. Create a heatmap of risk factor density attribute from the spatial 
polygons, optionally weighted by an attribute file that is associated with 
the risk 

3. Spatial lines risk factors e.g. of road network for legal (primary roads) or illegal animal 
movements (secondary roads) 

1. Import spatial lines file 

1. Browser Pane: Drag spatial lines file “gis_osm_roads_free_1” from 
RawData/Geo-Features/ onto map palette 

2. Subset road type required 

1. Select “gis_osm_roads_free_1” in Layers Pane 

2. Right click -> Open Attribute Table -> Click icon “Select/filter features 
using form”  from Attributes Table toolbar 

3. Select field to filter on 

4. On “fclass” row type in “primary” (the category will autofill) and the 
right hand option box should read “Contains” 

5. Click Select Features 

6. Close dialog box 

https://www.geodose.com/2017/11/qgis-heatmap-using-kernel-density.html
https://www.geodose.com/2017/11/qgis-heatmap-using-kernel-density.html


7. The selected features should be visible by highlighting 

3. Export the selected features as a new projected layer 

1. In the Layers pane, right-click the layer from which features have been 
selected -> Export -> Export Selected Features As … -> Dialog box 

1. Choose format (ESRI Shapefile) 

2. File name (ResData/Geo-Features/MMRRoadsPrim) 

3. CRS (Project CRS: …) 

4. Encoding (Ensure that “Save only selected features” is checked) 

5. Click OK 

4. Create a raster layer of distance from spatial polylines 

1. Convert polylines spatial object to a raster 

1. Layers Pane: Select and highlight polylines spatial object for 
analysis (ResData/Geo-Features/MMRRoadsPrim) 

2. Menu bar: Raster -> Conversion -> Rasterize (Vector to Raster) -> 
Dialog box 

1. Input shape file (“ResData/Geo-
Features/MMRRoadsPrim”) 

2. A fixed value to burn [optional]: set to 1 

3. Output raster size units: Select “Georeferenced units” 

4. Width/Horizontal resolution = 1000 

5. Height/vertical resolution = 1000 

6. Output extent  -> Calculate from layer (“ResData/Geo-
Admin/MMR_0”) 

7. Assign a specified nodata value to output bands [optional]: 
Toggle to “Not set” 

8. Click OK 

9. Click Run 

3. Export the newly-created rasterized layer and save as 
“ResData/Geo-Admin/MMRRoadsPrim_Rast” 

2. Create a raster of closest distances from raster of roads to study area 

1. Menu bar: Raster > Analysis > Proximity (Raster Distance) tool in 
QGIS -> Dialog box 

1. Input layer- select “ResData/Geo-
Admin/MMRRoadsPrim_Rast”) 

2. Distance units- select “Georeferenced coordinates” 

3. No data value to use for destination proximity raster: 
Toggle to “Not set” 

4. Click Run 

2. Export and save the newly created “Proximity map” layer as 
“MMRRoadsPrim_Rast_Prox” 

5. Repeat for secondary roads 



4. Spatial raster risk factors e.g. vector or reservoir or target species density from FAO 
Gridded Livestock of the World 

1. Pig population as indicator for risk of swill feeding 

1. Browser Pane: Drag “5_Pg_2010_Da.tif” onto map pane 

2. Reproject to Project projection 

1. In Layers Pane: Highlight file “5_Pg_2010_Da” 

2. Right click 

3. Export -> Save As … -> Dialog box: 

1. File name “Pig_2010_Da” in ResData/Geo-Livestock folder 

2. CRS: “Project CRS” 

3. Click OK 

3. Clip to UTM 86N study boundary file extent 

1. Layers Pane: Highlight “Pig_2010_Da” 

2. Menu Bar: Raster -> Extraction -> Clip raster by Extent -> Dialog 
box 

1. Input layer: “Pig_2010_Da” 

2. Clipping extent -> Calculate from layer “MMR_0” 

3. Click Run 

4. Export and save clipped raster with new name 

1. In Layers Pane highlight newly-created “Clipped (extent)” 

2. Right-click Export -> Save As … -> Dialog box 

1. Filename: “Pig_2010_Da_clip” in ResData/Geo-Livestock 
directory 

2. CRS: Project CRS: 

3. Click OK 

2. Repeat for cattle population density as an indicator of risk of susceptibility to 
outbreak 


